All residual jobs have drained. Storage performance and job activity is normal.
Posted Jun 13, 2026 - 00:40 UTC
Update
Job queues continue to drain. We will actively monitor until they are complete.
Posted Jun 12, 2026 - 23:57 UTC
Monitoring
Backlog is being effectively processed and operations have returned to normal. We continue to monitor the performance in us-west-2.
Posted Jun 12, 2026 - 20:26 UTC
Update
We are seeing improvement in the performance of us-west-2 after implementation of our mitigation strategies. Storage operation is returning to normal. We will continue to monitor performance in this region.
Posted Jun 12, 2026 - 19:30 UTC
Update
We have implemented further mitigations and are tracking their progress. We continue to actively work this issue.
Posted Jun 12, 2026 - 18:28 UTC
Update
The team is still working on a solution, and mitigation work is underway.
Posted Jun 12, 2026 - 17:29 UTC
Update
We are implementing load mitigation strategies to improve the performance of storage requests in US-West-2.
Posted Jun 12, 2026 - 16:30 UTC
Identified
Users in US-West-2 are seeing increased latency on storage requests. The team has identified the issue and is working on a solution.