Increased latency for Management API requests

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 14:19 UTC

Monitoring

Latency has returned to normal levels, and we are seeing greatly improved stability across the management API. We are monitoring for any further issues.
Posted Jun 23, 2026 - 13:39 UTC

Identified

We are seeing increased latency on management API requests, which results in slower-than-usual Dashboard performance, project creation and configuration changes may also be delayed. This is primarily affecting US-East-1; however, we are seeing additional latency in other regions as well.

The team has identified the issue and is working on resolution.
Posted Jun 23, 2026 - 13:21 UTC
This incident affected: Dashboard and Management API.